Delay in delivering email messages
Incident Report for ChurchDesk
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 02, 2019 - 11:42 CEST
Monitoring
Our mail provider has now confirmed that they are fully operational again.

Our email sending has been resumed and we expect all queued emails to be sent within the next 30 minutes.
Posted 7 months ago. Apr 02, 2019 - 11:35 CEST
Investigating
Our mail provider is currently experiencing a major outage and they are not able to send emails.

We are handling the mail queue on our end which means that all mails will be sent as soon as our provider has confirmed that the issue has been resolved.

This impacts all our services: People messages, calendar notifications, password reset emails and form submission receipts.

Please contact support@churchdesk.com if you have any questions.
Posted 7 months ago. Apr 02, 2019 - 10:28 CEST
This incident affected: ChurchDesk Application.