Service Disruption
Incident Report for ChurchDesk
Resolved
The root cause has been identified and resolved.
Posted over 1 year ago. Feb 20, 2018 - 14:18 CET
Identified
The customer websites are back online. We are still working on identifying the root cause.
Posted over 1 year ago. Feb 20, 2018 - 12:52 CET
Investigating
We're experiencing issues with customer websites. Currently we are investigating and will update this when we know more.
Posted over 1 year ago. Feb 20, 2018 - 11:15 CET