Service Disruption
Incident Report for ChurchDesk
Resolved
We have confirmed that the application has returned to normal operations.
Posted Mar 22, 2020 - 16:45 CET
Monitoring
We have confirmed that the application and websites are up and running again, but are closely monitoring to ensure that it is completely stabilised. We're sorry for the inconvenience.
Posted Mar 22, 2020 - 16:13 CET
Update
We're experiencing a service disruption and all parts of the system seem to be affected. The websites appear to be partially working, but some elements may not be loading. We're currently looking into the issue and will keep you updated.
Posted Mar 22, 2020 - 15:19 CET
Investigating
We're experiencing service disruption and are currently looking into the issue.
Posted Mar 22, 2020 - 14:28 CET
This incident affected: ChurchDesk Application, Websites, iOS App, Android App, and ChurchDesk API.