Service Disruption
Incident Report for ChurchDesk
Resolved
This incident has been resolved.
Posted Mar 20, 2021 - 15:29 CET
Identified
The issue has been identified and a fix is being implemented
Posted Mar 20, 2021 - 15:10 CET
Investigating
We're experiencing service disruption with the ChurchDesk websites and are currently looking into the issue.

Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Mar 20, 2021 - 14:26 CET
This incident affected: Websites.