Investigating degraded performance
Incident Report for ChurchDesk
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 14:45 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2021 - 10:51 CET
Investigating
We are investigating degraded performance in the ChurchDesk Websites. Our team is currently investigating.

We will send an additional update in 30 minutes.
Posted Mar 23, 2021 - 10:35 CET
This incident affected: Websites.