Investigating degraded performance
Incident Report for ChurchDesk
Resolved
The incident has now been resolved and the application is now back to normal operations. We’re sorry for any inconvenience this may have caused. If you have further questions please contact us at support@churchdesk.com.
Posted 2 months ago. May 09, 2019 - 14:37 CEST
Investigating
We are investigating degraded performance in the ChurchDesk Application (Web and Mobile).
Posted 2 months ago. May 09, 2019 - 14:02 CEST
This incident affected: ChurchDesk Application, ChurchDesk API, iOS App, and Android App.