Service Disruption
Incident Report for ChurchDesk
Resolved
This incident has been resolved.
Posted Mar 24, 2021 - 11:01 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2021 - 10:48 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 24, 2021 - 09:56 CET
Investigating
We're experiencing service disruption for the ChurchDesk Websites.
Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Mar 24, 2021 - 09:42 CET
This incident affected: Websites.