Investigating
Incident Report for ChurchDesk
Resolved
The incident has now been resolved and the application is now back to normal operations.
Please make sure to refresh the page if you still experience any issues.
(Windows users can press F5. Mac users can press CMD+R).

We’re sorry for the inconvenience this have caused.

If you have further questions please contact us at support@churchdesk.com
Posted 7 months ago. Feb 01, 2019 - 09:23 CET
Monitoring
We have confirmed that the application is up and running again, but are closely monitoring to ensure that it is completely stabilised. We're sorry for the inconvenience.
Posted 7 months ago. Feb 01, 2019 - 09:15 CET
Update
All browsers are affected. Our team is still looking into the cause and we'll continue to update you on our progress.
Posted 7 months ago. Feb 01, 2019 - 09:07 CET
Investigating
We've received word that Internet explorer users are having troubles with ChurchDesk. We're currently investigating the issue, and will have updates shortly.
Posted 7 months ago. Feb 01, 2019 - 08:22 CET
This incident affected: ChurchDesk Application.