Homepage Service Disruption
Incident Report for ChurchDesk
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 03, 2018 - 12:23 CEST
Investigating
We're experiencing a service disruption on some customer homepages, that unfortunately prevents some homepages to open. We are looking into the issue and will update you as soon as possible.
Posted about 1 year ago. Sep 03, 2018 - 11:53 CEST
This incident affected: ChurchDesk Application, Websites, iOS App, and Android App.