Service Disruption
Incident Report for ChurchDesk
Resolved
This incident has been resolved.
Posted 20 days ago. Jul 02, 2019 - 17:46 CEST
Monitoring
We have confirmed that the application has returned to normal operations. Our DNS provider Cloudflare went down momentarily which caused connection issues to ChurchDesk Forms, Payments and People.

We also observed other providers being hit such as our support system, Intercom.
Posted 20 days ago. Jul 02, 2019 - 16:18 CEST
Investigating
We're experiencing a service disruption on our forms and payments modules and are currently looking into the issue.

Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted 20 days ago. Jul 02, 2019 - 15:59 CEST
This incident affected: ChurchDesk Application.