Service Disruption
Incident Report for ChurchDesk
Resolved
The incident has now been resolve and the application is now back to normal operations.

If you have further questions please contact us at support@churchdesk.com
Posted Jun 14, 2021 - 14:32 CEST
Monitoring
We have confirmed that the application is up and running again, but are closely monitoring to ensure that it is completely stabilised. We're sorry for the inconvenience.
Posted Jun 14, 2021 - 14:07 CEST
Investigating
We're experiencing service disruption and are currently looking into the issue.

Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Jun 14, 2021 - 13:56 CEST
This incident affected: ChurchDesk Application, Websites, iOS App, Android App, and ChurchDesk API.