Access to People and Forms
Incident Report for ChurchDesk
Resolved
This incident has now been resolved. We apologize for the inconvenience
Posted May 21, 2020 - 12:58 CEST
Investigating
You are currently not able to access your contacts and forms in ChurchDesk. We have identified the issue and we have a team of developers investing the issue and expect to resolve it quickly. The underlying issue is also affecting the ability to add files to newsletters and websites via the Linkit feature.

We will keep you updated on the progress on this page. We apologize for the inconvenience.
Posted May 21, 2020 - 10:53 CEST
This incident affected: ChurchDesk Application, iOS App, and Android App.