Service Disruption
Incident Report for ChurchDesk
Resolved
We have confirmed that the application has returned to normal operations.
Posted 11 months ago. Dec 05, 2018 - 19:59 CET
Investigating
We're experiencing service disruption and are currently looking into the issue.
Posted 11 months ago. Dec 05, 2018 - 19:26 CET
This incident affected: ChurchDesk Application, Websites, ChurchDesk API, iOS App, and Android App.