Service Disruption
Incident Report for ChurchDesk
Resolved
The update is still running and will be for the next couple of hours. We are now closing this incident since there is no impact on customer websites. All websites are fully operational.

If you have further questions please contact us at support@churchdesk.com
Posted over 1 year ago. May 04, 2018 - 16:36 CEST
Investigating
Some customers might experience their ChurchDesk Website not working. This is due to a very heavy update currently running.
Posted over 1 year ago. May 04, 2018 - 09:41 CEST
This incident affected: Websites.