Service Disruption
Incident Report for ChurchDesk
Resolved
We have confirmed that the application has returned to normal operations.
Posted 3 months ago. May 19, 2019 - 04:32 CEST
Monitoring
We have confirmed that the application is up and running again, but are closely monitoring to ensure that it is completely stabilised. We're sorry for the inconvenience.
Posted 3 months ago. May 19, 2019 - 04:28 CEST
Investigating
We're experiencing service disruption and are currently looking into the issue.
Posted 3 months ago. May 19, 2019 - 04:05 CEST
This incident affected: ChurchDesk Application, Websites, ChurchDesk API, iOS App, and Android App.