ChurchDesk People
Incident Report for ChurchDesk
Resolved
We have confirmed that the ChurchDesk People/Contacts module has returned to normal operations.
Posted 9 months ago. Dec 06, 2018 - 10:24 CET
Monitoring
We have confirmed that the ChurchDesk People/Contacts is working again, but are closely monitoring to ensure that it is completely stabilised. We're sorry for the inconvenience.
Posted 9 months ago. Dec 06, 2018 - 09:44 CET
Investigating
The ChurchDesk People/Contacts module is currently experiencing errors. We are working to quickly resolve the issues. Apologies for the inconvenience.
Posted 9 months ago. Dec 06, 2018 - 09:31 CET
This incident affected: ChurchDesk Application, iOS App, and Android App.