Investigating

Major incident ChurchDesk Application ChurchDesk Websites ChurchDesk Mobile App ChurchDesk API
25-08-2026 14:35 CEST · 8 minutes

Updates

Resolved

The incident has now been resolved and the application is now back to normal operations.

We’re sorry for any inconvenience this may have caused. We have identified the root cause and made sure that this or similar technical issues should not happen again.

August 25, 2026 · 14:43 CEST
Update

We have identified the root cause of the current disruption and are implementing a fix to get ChurchDesk back online as quickly as possible. We will provide regular updates on our progress.

August 25, 2026 · 14:38 CEST
Issue

We’ve received word that some users are having troubles with ChurchDesk. We’re currently investigating the issue, and will have updates shortly.

August 25, 2026 · 14:25 CEST

← Back