Investigating

Major incident ChurchDesk Application ChurchDesk Mobile App ChurchDesk API
05-02-2026 10:11 CET · 15 minutes

Updates

Resolved

The incident has now been resolved and the application is now back to normal operations.

We’re sorry for any inconvenience this may have caused.

February 5, 2026 · 10:21 CET
Issue

We’re currently investigating login issues for https://app.churchdesk.com, and will have updates shortly.

February 5, 2026 · 10:11 CET

← Back