Service Disruption
Incident Report for ChurchDesk
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 20:20 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2021 - 19:46 CET
Investigating
We're experiencing service disruption for ChurchDesk websites.

Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.
Posted Mar 23, 2021 - 19:21 CET
This incident affected: Websites.