Investigating
Minor incident
ChurchDesk Application
14-05-2025 12:11 CEST
· 50 minutes
Updates
Resolved
May 14, 2025 · 13:02 CEST
The incident has now been resolved and the application is now back to normal operations.
We’re sorry for any inconvenience this may have caused. We have identified the root cause and made sure that this or similar technical issues should not happen again.
Monitoring
May 14, 2025 · 12:44 CEST
We have confirmed that the application is up and running again, but are closely monitoring to ensure that it is completely stabilised. We’re sorry for the inconvenience.
Update
May 14, 2025 · 12:38 CEST
We are working on a fix to get ChurchDesk up and running again. We will keep you updated on the progress.
Issue
May 14, 2025 · 12:11 CEST
We’ve received word that some users are having troubles with ChurchDesk. We’re currently investigating the issue, and will have updates shortly.
← Back