Resolved

Major incident ChurchDesk Application ChurchDesk Mobile App ChurchDesk API
25-04-2025 18:08 CEST · 1 hour, 4 minutes

Updates

Issue

We have confirmed that everything is up and running and stable again.

April 25, 2025 · 19:10 CEST
Monitoring

We have confirmed that the application is up and running again, but are closely monitoring to ensure that it is completely stabilised. We’re sorry for the inconvenience.

April 25, 2025 · 18:48 CEST
Issue

We’ve received word that some users are having troubles with ChurchDesk. We’re currently investigating the issue, and will have updates shortly.

April 25, 2025 · 18:08 CEST

← Back