Service Disruption

Major incident ChurchDesk Application ChurchDesk Websites ChurchDesk API
05-06-2024 06:44 CEST · 9 hours, 43 minutes

Updates

Resolved

The incident has now been fully resolved and the application is now back to normal operations.

We have identified the root cause and will be making changes to make sure that this or similar technical issues does not happen again.

We’re sorry for any inconvenience this may have caused.

June 5, 2024 · 16:20 CEST
Monitoring

We have confirmed that the application is up and running again, but are closely monitoring to ensure that it is completely stabilised. We’re sorry for the inconvenience.

We will be providing an update later with more information and steps implemented to avoid this in the future.

June 5, 2024 · 11:13 CEST
Investigating

Our team is still looking into the cause of the issues, and we’ll continue to update you on our progress.

What is affected?

  • Background jobs such as email sending and creating users
  • Files, documents and images
June 5, 2024 · 08:56 CEST
Investigating

Our team is still looking into the cause of the issues, and we’ll continue to update you on our progress.

The ChurchDesk file archive is not working whereas some images on your ChurchDesk websites might still work.

June 5, 2024 · 07:16 CEST
Issue

We’re experiencing service disruption related to documents and images and are currently looking into the issue.

Our team is working to identify the root cause and implement a solution.

We will send an additional update in 30 minutes.

June 5, 2024 · 06:44 CEST

← Back