Service Disruption

Major incident ChurchDesk Application ChurchDesk Websites ChurchDesk Mobile App ChurchDesk API
09-11-2023 07:25 CEST · 2 hours, 32 minutes

Updates

Resolved

We have confirmed that the application has returned to normal operations.

November 9, 2023 · 07:53 CEST
Investigating

We’re experiencing service disruption and are currently looking into the issue.

November 9, 2023 · 07:25 CEST

← Back