New Websites currently not available

Major incident ChurchDesk Websites
14-11-2023 08:18 CEST · 1 hour, 42 minutes

Updates

Resolved

The incident has been resolved.

November 14, 2023 · 10:00 CEST
Monitoring

We have isolated the problem and implemented the changes needed and we are monitoring.

November 14, 2023 · 09:54 CEST
Investigating

We are investigating an issue with the web editor and some sites being unreachable.

November 14, 2023 · 08:18 CEST

← Back