Mobile Service Disruption (iPhone and Android)
Incident Report for ChurchDesk
Resolved
Our team has identified and resolved the issue of why the mobile application could not open. Everything is now back to normal but we’ll keep monitoring.

As always, if you have any questions or issues, please send them to support@churchdesk.com.
Posted Jun 23, 2020 - 14:05 CEST
Investigating
We're experiencing a service disruption on our mobile application preventing the mobile application from opening.

Our team is working to identify the root cause and implement a solution. All users using the latest version of our mobile application is affected. Please do not update to the newest version.

We will send an additional update in 30 minutes.

We appreciate your patience and understanding. As always, if you have questions or issues, please submit them to support@churchdesk.com
Posted Jun 23, 2020 - 13:32 CEST
This incident affected: iOS App and Android App.