Get in touch
Back
Maintenance

Scheduled maintenance

Completed 20 Dec at 12:01am CET.

ChurchDesk Websites ChurchDesk Web Application ChurchDesk Mobile App ChurchDesk API
Completed

Posted 20 Dec at 12:01am CET.
Started

We want to make you aware that today Monday December 19 at 23:00 CET, there will be a scheduled down time for approximately 1 hour.
During this maintenance window, the ChurchDesk platform will be inaccessible and email delivery paused.
We appreciate your patience and understanding. As always, if you have questions or issues, please submit them to support@churchdesk.com

Thanks,

Posted 19 Dec at 11:00pm CET.