Get in touch
Back
Downtime

Service Disruption

Started 10 Nov at 12:38pm CET, resolved 10 Nov at 12:45pm CET.

ChurchDesk Websites ChurchDesk Web Application ChurchDesk Mobile App ChurchDesk API
Resolved

We have confirmed that the application has returned to normal operations.

Posted 10 Nov at 12:45pm CET.
Created

We're experiencing service disruption and are currently looking into the issue.

Posted 10 Nov at 12:38pm CET.